⚠️この投稿は投稿者からの報告です。出版社による確認が完了していない情報を含みます。
正誤情報連絡済み(管理者が出版社または著者へ連絡しました。出版社から回答があれば「出版社からの回答」に表示されます。)
RFC 6854 → RFC 1123
nkn-ms @1034b8a2投稿日時: 2026-07-28 09:26:27編集日時: -
版・刷
第1版 第10刷
位置
p.114
補足
114Pのコラム 表4-3 HTTPヘッダ内で利用できる日時の形式
正誤情報
誤
RFC 822, updated by RFC 6854正
RFC 822, updated by RFC 1123備考
コラムの本文中ではRFC 1123が用いられてる旨が記載されているが、表には記載がないので気になって調査したところ(AIに投げたら) RFC 2616 に日時の形式をまとめた表があり(参考画像の2枚目) https://datatracker.ietf.org/doc/html/rfc2616#section-3.3.1 誤りであると強い確証を得たので投稿に至る。というか本文中に表の内容はRFC2616からの引用の記載あり RFC 822はarpnetにおけるテキストメッセージの仕様(電子メールの仕様の原型となる)、ここを源流にRFC 6854まで発展しているのでRFC 822がRFC 6854にupdateされていること自体は間違いではないが 日時形式に限定した場合RFC 1123(インターネットにおけるホスト[コンピュータ]の規則の仕様。ここで日時形式を規定)が適切だと考える。
同じ誤りを見つけた方は賛同で知らせられます

